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Install MediaRecorder

IMPORTANT - If you have an older version of MediaRecorder - Uninstall MediaRecorder 6.0 and older
versions before you install MediaRecorder 6.5.

To install MediaRecorder 6.5

Download the installation files from my.noldus.com, and extract the contents.
Double-click the file MediaRecorder [Version number] Setup.exe.

Under Installation type, select Standard.

In the Drivers and tools field, choose the driver of your video device.

Click Next, accept the End-User License Agreement and click Install.

vk wnH

Notes
e See Specifications for the supported devices.

e See Recording Devices for specific information on your device like the maximum number of
cameras you can use simultaneously and the maximum supported frame rate and
resolution.
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Set up MediaRecorder

up and running quickly

This Quick Start Guide guides you through the main steps to record video with MediaRecorder. This Quick Start
Guide contains basic information on MediaRecorderfunctionalities. It does not contain information how to connect
and setup your cameras. Also, it does not contain information on the prerequisites and restrictions for specific
camera types. You can find this additional information in the MediaRecorder Help. Press F1 in the program to
open it, or type MediaRecorder Help in the Windows apps screen.

start mediarecorder

1. Connect all cameras and microphones to the computer with MediaRecorder.
2. Depending on your license, do one of the following:

e If you have a hardware key - Insert it into a USB port of the computer and start
MediaRecorder.
e Start MediaRecorder and activate your software license key. You can choose between a
Floating or a Fixed activation.
o Floating — Choose Floating if you want to be flexible on which computer you use
MediaRecorder and your computer is connected to the internet.
o Fixed — A Fixed activation is linked to one computer. Your computer must have an
internet connection to activate/deactivate a fixed license. After you have activated the
license you can use MediaRecorder without internet.

The first time MediaRecorder opens, the preview window is black. That is because you still have to select the
cameras. Proceed with the next steps to do so.
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select cameras

1. Choose File > Video Settings, or click Video Settings in the main window.

- |

Mute Volume % File location: ChlUsersiPubliciDocuments\MoldusiMedii| | ., | |5

File base name: Videao

Cutput mode:
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Video Settings | Refresh

TIP If the Video Settings button is not visible, the recording properties may be closed. Click Recording
properties at the bottom of your window.

»  Recording properties
Mot recording

2. Select your camera from the Video device list.

Use Video name Yideo device F

1 | | Video 1 My | Select video device... W



https://bookstack.noldus.com/uploads/images/gallery/2023-12/66CDwDm4N01XG45d-media-recorder-6-5-first-screen.png
https://bookstack.noldus.com/uploads/images/gallery/2023-11/57ZblYDKVdEB0uJs-image.png
https://bookstack.noldus.com/uploads/images/gallery/2023-11/qrttTc8OAxFl0KWR-image.png
https://bookstack.noldus.com/uploads/images/gallery/2023-11/97neZ3eE4trIlb60-image.png

See Set up IP cameras in the MediaRecorder Help how to select IP cameras.
. Select the frame rate and resolution.

Use Video name Video device Frame rate Resolution
1 Wideo 1 Microsoft LifeCam Studio &=+ 30.00 1280 x 720 udi
2 | [ |video 2 Select video device. ..
3 Video 3 Select video device...

. For advanced camera settings, click the video symbol next to the name of your camera.
The available options depend on your camera. For some cameras you can zoom and adjust
settings for brightness and contrast.

Use Video name YVideo device rame rate
1 Video 1 !Micrc-sclft LifeCam Studio 00
7 | [ |video 2 Select video device...

. Optionally change the names in the Video name column, to, for example,
Overview camera, or Close-up participant 1.

. To record audio as well, continue with select microphones.

. Optionally, select some additional settings for your video files. See Options.
. When satisfied with the settings, click OK to leave the Video Settings window and start

recording. See Record video.

select microphones

1. Select the microphones from the Audio device list. Choose between your

computer microphone, a separate microphone, or the audio stream of your camera. Choose
No audio to not record audio.
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Audio name Audio device

Audio 1 Mo Audic W

sudia 2 Headset Mic [Realtek High Definitio
Jack Mic [Fealtek High Definition Au

Audio 3 Microphone Array (Realtek High Def

L RT5P IP Camera [Moldus RTSP Source

Audio 4 Mo Audio

Audio 5 Mo Audio

2. Optionally, record the same audio stream in all videos. To do so, select this checkbox. (
Please note that in Picture-in-Picture mode, you may select which audio source to use for all

the videos. See Select an audio device).

Cutput settings

Qutput mode: | Separate videos W
4

PiP 5ize: 2050
PiP Margin: Go%5

Use audio device 1 for all videos

3. Optionally, click the microphone button for advanced audio settings.

Settings
Frame rate  Resolution Audio name Audio device
5.00 1280 x 200 Audio Microphone [High Definitio...
Advanced audio settings
0.00 1280 x 800

The available options depend on your microphones. Move the sliders to adjust the recording

volume.
4. Optionally, change the names in the Audio name column.
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To check the recording volume

1. Right-click the speaker icon in the bottom-right corner of your window and select
Recording devices.

Open Volume Mixer

Playback devices

Recording devices % ‘

Sounds

pr - Velume contrel options

4:46 PM
8/5/2015

=

2. Check that the green bar is maximal when speech level is normal.
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Playback | Recording | Sounds | Communications

Select a recording device below to modify its setfings:

" 4

Microphone
High Definition Audio Device
Disabled

Microphone
Y High Definition Audio Device
Default Device
7

Microphone
High Definition Audio Device

-% Mot plugged in

3. Continue with Options, or click OK to close the Video Settings window and start recording.

Note

Audio is needed and has been tested only for cameras that are supported with The Observer XT. See Recording
Devices in the MediaRecorder Help which cameras are.
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Options

For a full overview of the options, see the MediaRecorder Help.

set arecording time

1. Choose File > Video Settings.
2. Select Use maximum recording time and enter the time.

Timer settings

Time formatt  HH'mm:ss W
Decimals: 0 b

Example: 16:43:52

Use maximum recording time:

QK Cancel Apply

select output settings for multiple cameras

If you have selected more than one video source, MediaRecorder can create a separate video file for each
camera, but also one video of all camera streams. Choose File > Video Settings and select one of the options
under Output Settings. The following options are available:

e Separate videos — One video file for each camera.

e Picture by Picture — One video file with the images from each camera next or above
each other.
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e Picture in Picture — One video file with a large image of the first camera with the images from the other
cameras embedded in it.

If you select this option the following settings become available:

e PiP Position — The position of the embedded images.

e Pip Size — The size of the embedded images. The percentage is based on the width of the
first camera image. The aspect ratios of the embedded camera images are maintained.

¢ Pip Margin — The margin of the embedded images. When the percentage is zero, the
embedded images are positioned directly on the edge of the main image. The percentage is
based on the width of the first camera image.

Note

If possible, choose the same frame rate for all the videos for Picture in Picture or Picture by Picture. If you choose
different frame rates the videos with the lowest frame rates may flicker.
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manage video files

To select the video file location

The default location where MediaRecorder stores its video files is:

e D:\Noldus\MediaRecorder\Video Files — If Noldus IT installed your system
e C:\Users\Public\Public Documents\Noldus\MediaRecorder\Video Files — In all other cases.

To change the default location, click the button next to the File location field of the main MediaRecorder window
and select another folder.

lume File location: | D:\Noldus\Media Recorder 4\Videa Filds Ej
File base name: Video
Cutput mode:
W
Refresh

You must have writing rights in this folder. Also make sure that there is enough disc space. Dependent on the
recording device, frame rate, resolution and amount of movement, MediaRecorder videos can be up to 600 Mb
per hour.

To select a file base name

The name of the recorded video file consists of the File base name followed by:

e The video input name.

e The date and the time the videos were recorded. The format of the date and time depends
on the computer’s regional settings.

e The number of the video camera.

_Volume # File location: ublic\Documents\Noldus\MediaRecorder\Video Files| | .. || [
File base name: Video
v Output mode:

Refresh

save the settings

The settings you create for the different cameras are automatically saved when you close MediaRecorder. They
are saved to the file Current settings.mrs that is present in the folder C:\Users\Public\Public
Documents\Noldus\MediaRecorder. These settings are used when you restart MediaRecorder. But you can also
save your own settings, or save different settings for different setups, for example, a webcam for a test
participant’s face in a usability test room and three overview IP cameras in an observation room. This way you do
not have to select all cameras manually each time.
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Procedure

1. Choose File > Save Configuration As.
2. Give the configuration a name and click Save.

To open a saved configuration

Choose File > Open configuration and select a .mrs file.

Notes
e important Never shut down the computer by pressing the power button or cutting off the
electricity. Always use the Windows shut down feature to close your computer.
e To go back to the default configuration, choose File > Open Configuration. Open the file
Default Settings.mrs.



Record video

When you selected all cameras, you see a preview in the main MediaRecorder window.

a3 Miitia Abccise 45 = O “
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TIP If you selected multiple microphones, it can be useful to mute all but one audio channel in the preview. Select
the audio source in the Mute column of the table under the preview. Muting audio in the preview does not
influence the recording.

Mr Use Video name Audio name Mute | Volume %™
1 | Video 1 Audio 1

2 | | Video 2 Audio 2

3 | | Video 3 Audio 3 v
- Jideo 4 Audio 4 v
|dentify Video Settings Refresh

To start recording, press the Start recording button.
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Mute Volume ™

o

Video Settings Refresh

A pop-up window will appear, informing you about Noldus's Data Transparency Policy. Read it carefully before
clicking the 1 will inform the participants button. You can also check the box Don't show me again to prevent
further occurrence.
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Data transparency >

Rezponzible Lse
|rformed consent

Yaou are starting the recording. Before pou continue, if your study invalves human subjects,
pleaze infarm the participants in your study what vou will be daing with their data and why. Make sure
wou have therr conzent to take part in the rezearch.

Drata Transparency
By clicking the QF button, vou acknowledge vour rezponzibility to inform the participants about;

+ which data iz collected

+ Haow the data will be uzed

+ where the data will be stored

+ o will have access to the data

+ what the collected data will not be uzed for

+ How the participant will benefit fram the data collection

Idze of MediaRecorder iz subject to certain restrictions, which are documented in zection 7 of the End-
Uger License dgreement,

[] Dont show me again | will inform the participants

The button then changes into the Stop Recording button and the Recording timer starts running.

E Participant 1 Audio 3
3 Overview cam 1 Audio 2
4 Participant 2 Audio 4
|dentify

Recording: 00:00:03 (hh:mm:ss) @

Press the button again to stop recording. Recording stops automatically when you specified a recording time .

how to access the recorded videos

To quickly access the recorded videos, press the Open target folder button in the main MediaRecorder window.
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File location:

File base name:

Cutput mode:

CoUsers\Public\Documentsi\Maoldusi\Medii| | .., @

Video

Open target folder

The video files are stored in the default video file location, or the location you specified. See To select the video

file location.
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For more information

mediarecorder help

The MediaRecorder Help opens when you press F1 in the program. It can also be accessed in the Windows apps
screen, and can be downloaded from the MyNoldus portal. From the Help menu select Noldus Online and then
MyNoldus portal.

training courses

Noldus offers training courses to help you get the most out of our software/hardware. In addition to on-site
courses at your lab and in-house courses at our headquarters in Wageningen (The Netherlands) and Leesburg
(VA, USA), we offer remote training courses.

Remote trainings are available in the same range of languages as on-site courses. Please contact your sales
representative for more information about trainings.

support

If you encounter problems, contact Noldus Technical Support, from the Help menu select Noldus Online and
then MyNoldus portal and submit a support case or find a helpdesk in your region.



